Межсайтовый скриптинг в GetSimple CMS

Дата публикации:
11.05.2010
Дата изменения:
11.05.2010
Всего просмотров:
1930
Опасность:
Низкая
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:P/RL:T/RC:C) = Base:5/Temporal:4.1
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:T/RC:C) = Base:5/Temporal:3.8
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GetSimple CMS 2.x
Уязвимые версии: GetSimple CMS 2.01, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в URL в сценариях admin/components.php, admin/resetpassword.php, admin/settings.php, admin/support.php, admin/theme-edit.php, admin/theme.php, admin/archvie.php, admin/edit.php, admin/image.php, admin/log.php, admin/pages.php и admin/upload.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в HTTP заголовке "Referer" в сценарии admin/changedata.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: get-simple.info

Решение: Установите исправление из SVN репозитория производителя.

Ссылки: http://code.google.com/p/get-simple-cms/source/detail?r=133

или введите имя

CAPTCHA