Межсайтовый скриптинг в vBulletin

Дата публикации:
11.05.2010
Дата изменения:
11.05.2010
Всего просмотров:
1953
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:P/RL:U/RC:C) = Base:5/Temporal:4.5
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
vBulletin 3.x
vBulletin 4.x
Уязвимые версии: vBulletin 3.8.4 PL2 и 4.0.3, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных при обработке BB Code тегов. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости требуется, чтобы во время преобразования "Custom BB Code" тегов в HTML теги не использовались кавычки.

URL производителя: www.vbulletin.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://forum.intern0t.net/intern0t-advisories/2528-vbulletin-3-8-4-pl2-4-0-3-pl1-insecure-custom-bbcode.html

или введите имя

CAPTCHA