Уязвимость при обработке XPM файлов в NetPBM

Дата публикации:
10.02.2010
Всего просмотров:
741
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:C/I:C/A:P/E:U/RL:O/RC:C) = Base:9/Temporal:6.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
NetPBM 10.x
Уязвимые версии: NetPBM версии до 10.35.72

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки в утилите "xpmtoppm" при обработке определенных XPM файлов. Удаленный пользователь может с помощью специально сформированного XPM файла вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: netpbm.sourceforge.net

Решение: Установите последнюю версию 10.35.72 с сайта производителя.

Ссылки: https://bugzilla.redhat.com/show_bug.cgi?id=546580

или введите имя

CAPTCHA