Переполнение буфера в RPM Select и Elite

Дата публикации:
15.04.2010
Дата изменения:
15.04.2010
Всего просмотров:
1565
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:C/I:C/A:C/E:U/RL:U/RC:C) = Base:9.3/Temporal:7.9
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
RPM (Remote Print Manager) Elite 5.x
RPM (Remote Print Manager) Select 5.x
Уязвимые версии:
RPM Select 5.0.70.6, возможно другие версии.
RPM Elite5.0.70.6, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при попытке изменить опции трансформации. Удаленный пользователь может с помощью специально сформированного файла, содержащего слишком длинный элемент "lfFaceName", вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: lpd.brooksnet.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.corelan.be:8800/index.php/forum/security-advisories/corelan-10-024-rpm-selectelite-local-buffer-overflow/

или введите имя

CAPTCHA