Межсайтовый скриптинг в vBulletin

Дата публикации:
24.03.2010
Дата изменения:
24.03.2010
Всего просмотров:
1459
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:P/RL:O/RC:C) = Base:5/Temporal:3.9
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
vBulletin 4.x
Уязвимые версии: vBulletin версии до 4.0.2 Patch Level 2

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "query" в сценарии search.php, когда параметр "search_type" равен "1". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.vbulletin.com

Решение: Установите последнюю версию 4.0.2 Patch Level 2 с сайта производителя.

Ссылки: http://www.vbulletin.com/forum/showthread.php?346486-Security-Fix-Releases-3.7.7-and-4.0.2-PL-2
http://inj3ct0r.com/exploits/9697

или введите имя

CAPTCHA