Множественные уязвимости в Limny

Дата публикации:
21.03.2010
Дата изменения:
21.03.2010
Всего просмотров:
1239
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:U/RC:C) = Base:7.5/Temporal:6.4
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Limny 2.x
Уязвимые версии: Limny 2.01, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности, произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "q" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "theme" и "language" в сценарии index.php, когда параметр "q" установлен в значение "user". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "tags" и "category" в сценарии index.php, когда параметр "q" равен "admin/modules/post/new". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости требуются привилегии на создание сообщений. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

4. Уязвимость существует из-за недостаточной обработки входных данных при обработке сгенерированных пользователями форм. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

5. Уязвимость существует из-за недостаточной обработки входных данных в параметре "name" в сценарии index.php, когда параметр "q" равен "admin/modules/form/elements". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимостей требуются привилегии на редактирование форм. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

6. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "pageslinksby", "itemsseperator" и "datetimetype" в сценарии index.php, когда параметр "q" равен "admin/modules/page/options". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости требуются привилегии на изменение опций страниц. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

7. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "numberofposts", "numberofpages", "showsummaryinfullview", "postlinksby", "itemsseperator", "postsseperator" и "datetimetype" в сценарии index.php, когда параметр "q" равен "admin/modules/post/options". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

8. Уязвимость существует из-за недостаточной обработки входных данных в параметре "email" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

9. Уязвимость существует из-за недостаточной обработки входных данных в параметре "content" в сценарии index.php, когда параметр "q" равен "admin/modules/block/new". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости требуются привилегии на создание блоков.

10. Уязвимость существует из-за недостаточной обработки входных данных в параметре "name" в сценарии index.php, когда параметр "q" равен "admin/modules/navigation". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости требуются привилегии на создание новых элементов навигации.

11. Уязвимость существует из-за недостаточной обработки входных данных в параметре "text" в сценарии index.php, когда параметр "q" равен "admin/modules/page/new". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости требуются привилегии на создание страниц.

12. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "summary" и "text" в сценарии index.php, когда параметр "q" равен "admin/modules/post/new". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости требуются привилегии на создание новых сообщений.

13. Уязвимость существует из-за недостаточной обработки входных данных при отправке сгенерированных пользователем форм. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

14. Уязвимость существует из-за генерации предсказуемого кода на странице восстановления пароля в сценарии modules/user/forgotpw.php. Злоумышленник восстановить пароли произвольных учетных записей.

15. Уязвимость существует из-за генерации предсказуемого кода в механизме подписок в сценарии modules/user/signup.php. Удаленный пользователь может обойти подтверждение регистрации по email и создать произвольное количество учетных записей пользователей.

16. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "block[title]" and "block[content]" parameters in themes/gray/block.php, "settings[footer]" и "settings[version]" в сценарии themes/gray/footer.php, в параметрах "settings[site]" и "settings[title]" в сценарии themes/gray/header.php, в параметрах "lang[direction]", "page[title]", "settings[title]", "lang[encoding]" и "settings[version]" в сценарии themes/gray/page.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: www.limny.org

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA