Множественные уязвимости в eGroupWare

Дата публикации:
10.03.2010
Дата изменения:
10.03.2010
Всего просмотров:
1777
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
eGroupWare 1.x
Уязвимые версии: eGroupWare 1.6.002, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "lang" в сценарии login.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "spellchecker_lang" в сценарии phpgwapi/js/fckeditor/editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php. Удаленный пользователь может выполнить произвольные команды на системе.

URL производителя: www.egroupware.org

Решение: Установите последнюю версию 1.6.003 с сайта производителя.

Ссылки: http://www.egroupware.org/news?category_id=95&item=93

или введите имя

CAPTCHA