Множественные уязвимости в MediaWiki

Дата публикации:
10.03.2010
Дата изменения:
10.03.2010
Всего просмотров:
1088
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MediaWiki 1.x
Уязвимые версии: MediaWiki версии до 1.15.2

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности и получить доступ к важным данным.

1. Уязвимость существует из-за ошибки в функции проверки CSS. Злоумышленник может получить доступ к потенциально важным данным путем отображения картинок с внешних источников на страницах wiki. Для успешной эксплуатации уязвимости требуются привилегии редактора страниц.

2. Уязвимость существует из-за отсутствия проверки привилегий доступа в сценарии thumb.php. Удаленный пользователь может просмотреть запрещенные изображения на частных wiki страницах. Для успешной эксплуатации уязвимости требуется, чтобы схема аутентификации доступа к изображениям была настроена, например с помощью сценария img_auth.php.

URL производителя: wikipedia.sourceforge.net

Решение: Установите последнюю версию 1.15.2 с сайта производителя.

Ссылки: http://lists.wikimedia.org/pipermail/mediawiki-announce/2010-March/000088.html

или введите имя

CAPTCHA