Обход ограничений безопасности в PHP

Дата публикации:
03.03.2010
Дата изменения:
27.08.2010
Всего просмотров:
2070
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:S/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:5.5/Temporal:4.1
(AV:N/AC:L/Au:S/C:P/I:P/A:N/E:U/RL:O/RC:C) = Base:5.5/Temporal:4.1
CVE ID:
CVE-2010-1128
CVE-2010-1129
CVE-2010-1130
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 5.2.x
Уязвимые версии: PHP версии до 5.2.13

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности.

1. Уязвимость существует из-за ошибки в расширении session. Злоумышленник может обойти ограничения "safe_mode" и "open_basedir".

2. Уязвимость существует из-за ошибки в функции tempnam(). Злоумышленник может обойти ограничения "safe_mode".

URL производителя: www.php.net

Решение: Установите последнюю версию 5.2.13 с сайта производителя.

Ссылки: http://www.php.net/releases/5_2_13.php
http://securityreason.com/securityalert/7008
Журнал изменений: 27.08.2010
Незначительные изменения.

или введите имя

CAPTCHA