Переполнение буфера при обработке SSL сертификатов в Fetchmail

Дата публикации:
12.02.2010
Дата изменения:
12.02.2010
Всего просмотров:
12260
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Fetchmail 6.x
Уязвимые версии: fetchmail версии 6.3.11, 6.3.12 и 6.3.13

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции sdump() в файле sdump.c при вывод данных для полей issuer и subject для X.509 сертификата. Удаленный пользователь может с помощью специально сформированного SSL сертификата вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе. Для успешной эксплуатации уязвимости приложение должно быть запущено в режиме verbose на системе, где тип "char" является знаковым, и атакующий должен обманом заставить пользователя подключится к злонамеренному серверу.

URL производителя: www.tuxedo.org/~esr/fetchmail/

Решение: Установите последнюю версию 6.3.14 с сайта производителя.

Ссылки: http://fetchmail.berlios.de/fetchmail-SA-2010-01.txt

или введите имя

CAPTCHA