Межсайтовый скриптинг в Tinypug

Дата публикации:
12.02.2010
Дата изменения:
12.02.2010
Всего просмотров:
835
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Tinypug 0.x
Уязвимые версии: Tinypug 0.9.5, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов при выполнении некоторых действий. Удаленный пользователь может произвести CSRF нападение и изменить пароль администратора приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "comment_text" во время добавления комментария. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: code.google.com/p/tinypug/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.bugreport.ir/index_67.htm

или введите имя

CAPTCHA