Переполнение буфера в GMime

Дата публикации:
11.02.2010
Дата изменения:
11.02.2010
Всего просмотров:
1023
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GMime 2.x
Уязвимые версии: GMime версии до 2.4.15

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за того, что макрос GMIME_UUENCODE_LEN() некорректно вычисляет максимальное количество исходящих байт, сгенерированных для операции uuencode. Удаленный пользователь может с помощью специально сформированных данных вызвать двухбайтное переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: spruce.sourceforge.net/gmime/

Решение: Установите последнюю версию 2.4.15 с сайта производителя.

Ссылки: http://ftp.gnome.org/pub/GNOME/sources/gmime/2.4/gmime-2.4.15.changes

или введите имя

CAPTCHA