Множественные уязвимости в Moodle

Дата публикации:
08.12.2009
Всего просмотров:
2756
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-4297
CVE-2009-4298
CVE-2009-4299
CVE-2009-4301
CVE-2009-4302
CVE-2009-4305
CVE-2009-4300
CVE-2009-4303
CVE-2009-4304
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Moodle 1.8.x
Moodle 1.9.x
Уязвимые версии: Moodle версии до 1.8.11 и 1.9.7

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности, произвести XSS нападение, выполнить произвольные SQL команды и получить доступ к важны данным.

1. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов перед выполнением некоторых действий. Удаленный пользователь может произвести CSRF нападение.

2. Уязвимость существует из-за того, что модуль LAMS небезопасным образом отображает пользовательские данные.

3. Уязвимость существует из-за ошибки при обработке привилегий в сценарии mod/glossary/showentry.php. Удаленный пользователь может получить доступ к запрещенным статьям глоссария.

4. Уязвимость существует из-за ошибки при обработке привилегий доступа в интерфейсе MNET. Удаленный пользователь может выполнить MNET функции из любого зарегистрированного удаленного сервера.

5. Уязвимость существует из-за недостаточной обработки входных данных в некоторых параметрах в модуле SCORM. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

Также сообщается, что приложение передает учетные данные пользователя по незащищенному соединению.

URL производителя: moodle.org

Решение: Установите последнюю версию 1.8.11 или 1.9.7 с сайта производителя.

Ссылки: http://moodle.org/security/

или введите имя

CAPTCHA