Несколько уязвимостей в ncpfs

Дата публикации:
31.01.2005
Дата изменения:
01.02.2010
Всего просмотров:
835
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2005-0013
CVE-2005-0014
Вектор эксплуатации:
Локальная сеть
Воздействие:
Повышение привилегий
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ncpfs 2.x
Уязвимые версии: ncpfs версии до 2.2.6

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю повысить свои привилегии и скомпрометировать целевую систему.

1. Уязвимость существует из-за того, что некоторые утилиты небезопасным образом получают доступ к файлам. Локальный пользователь может с помощью специально сформированной символической ссылки или переменой окружения "HOME" повысить свои привилегии на системе.

2. Уязвимость существует из-за ошибки проверки границ данных ncplogin. Удаленный пользователь, контролирующий NetWare сервер, может вызвать переполнение буфера и скомпрометировать клиентскую систему.

URL производителя: freshmeat.net/projects/ncpfs/

Решение: Установите последнюю версию 2.2.6 с сайта производителя.

Журнал изменений:

01.02.2010
Обновлено описание уязвимости.

Ссылки: http://security.gentoo.org/glsa/glsa-200501-44.xml

или введите имя

CAPTCHA