Повреждение памяти в FASYNC в ядре Linux

Дата публикации:
26.01.2010
Дата изменения:
26.01.2010
Всего просмотров:
1840
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Отказ в обслуживании
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Linux Kernel 2.6.x
Уязвимые версии: Linux kernel 2.6.28 и более ранние версии.

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе.

Уязвимость существует из-за ошибки использования после освобождения при обработке дескрипторов файлов, с установленным флагом FASYNC. Локальный пользователь может вызвать отказ в обслуживании или выполнить произвольный код на системе с повышенными привилегиями.

URL производителя: www.kernel.org

Решение: Установите последнюю версию 2.6.31.12 или 2.6.32.4 с сайта производителя.

Ссылки: Linux Kernel FASYNC Use-After-Free PoC
http://archives.neohapsis.com/archives/fulldisclosure/2010-01/0252.html
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=log;h=53281b6d34d44308372d16acb7fb5327609f68b6

или введите имя

CAPTCHA