Выполнение произвольного кода в GNU gzip

Дата публикации:
21.01.2010
Дата изменения:
21.01.2010
Всего просмотров:
1618
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
gzip 1.x
Уязвимые версии: GNU gzip версии до 1.4

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Потеря значимости целочисленных обнаружена в функции unlzw() в файле unlzw.c. Удаленный пользователь может с помощью специально сформированного LZW архива выполнить произвольный код на целевой системе. Уязвимость распространяется только на 64-битные системы.

URL производителя: www.gzip.org

Решение: Установите последнюю версию 1.4 с сайта производителя.

Ссылки: http://savannah.gnu.org/forum/forum.php?forum_id=6153
http://git.savannah.gnu.org/cgit/gzip.git/commit/?id=a3db5806d012082b9e25cc36d09f19cd736a468f

или введите имя

CAPTCHA