Выполнение произвольного кода в GNU gzip

Дата публикации:
21.01.2010
Дата изменения:
21.01.2010
Всего просмотров:
1436
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
gzip 1.x
Уязвимые версии: GNU gzip версии до 1.3.13

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки входных данных в функции huft_build() в файле inflate.c. Удаленный пользователь может с помощью специально сформированного архива вызвать зацикливание приложения и выполнить произвольный код на целевой системе.

Уязвимость может относится к:
www.securitylab.ru/vulnerability/274087.php #1

URL производителя: www.gzip.org

Решение: Установите последнюю версию 1.3.13 с сайта производителя.

Ссылки: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507263
http://git.savannah.gnu.org/cgit/gzip.git/commit/?id=39a362ae9d9b007473381dba5032f4dfc1744cf2
http://article.gmane.org/gmane.comp.gnu.gzip.bugs/258

или введите имя

CAPTCHA