Переполнение буфера в pdftoabw в Poppler

Дата публикации:
16.11.2009
Всего просмотров:
578
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
poppler 0.x
Уязвимые версии: Poppler 0.12.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в утилите pdftoabw. Удаленный пользователь может с помощью специально сформированного PDF файла вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: poppler.freedesktop.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=534680
http://bugs.freedesktop.org/show_bug.cgi?id=23074

или введите имя

CAPTCHA