Уязвимость при расшифровке RC4 и AES в Kerberos KDC

Дата публикации:
19.01.2010
Всего просмотров:
1980
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Kerberos 5.x
Уязвимые версии: Kerberos версии до 1.6.4 и 1.7.1

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки потери значимости целочисленных при обработке AES и RC4 шифров, которые короче минимальной ожидаемой длины. Удаленный пользователь может с помощью специально сформированных данных вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: web.mit.edu/kerberos/www/

Решение: Установите исправление с сайта производителя.
Исправление для krb5-1.6:
http://web.mit.edu/kerberos/advisories/2009-004-patch_1.6.3.txt.asc

Исправление для krb5-1.7:
http://web.mit.edu/kerberos/advisories/2009-004-patch_1.7.txt.asc

Ссылки: http://web.mit.edu/kerberos/www/advisories/MITKRB5-SA-2009-004.txt

или введите имя

CAPTCHA