Множественные уязвимости в PHP

Дата публикации:
17.12.2009
Всего просмотров:
840
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-3557
CVE-2009-3558
CVE-2009-4017
CVE-2009-4142
CVE-2009-4143
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 5.2.x
Уязвимые версии: PHP версии до 5.2.12

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности и произвести XSS нападение.

1. Уязвимость существует из-за ошибки в функции tempnam(). Злоумышленник может обойти ограничения безопасности "safe_mode".

2. Уязвимость существует из-за ошибки в функции posix_mkfifo().Злоумышленник может обойти ограничения безопасности "open_basedir".

3. Уязвимость существует из-за ошибки при обработке загрузок файлов на основе форм. Удаленный пользователь может с помощью специально сформированного запроса вызвать отказ в обслуживании приложения.

4. Уязвимость существует из-за ошибок, относящихся к недостаточной защите $_SESSION от прерываний и недостаточной проверки session.save_path.

5. Уязвимость существует из-за недостаточной обработки входных данных в функции htmlspecialchars(). Удаленный пользователь может произвести XSS нападение.

URL производителя: www.php.net

Решение: Установите последнюю версию 5.2.12 с сайта производителя.

Ссылки: http://www.php.net/releases/5_2_12.php
http://bugs.php.net/bug.php?id=49785
http://securityreason.com/securityalert/6600
http://securityreason.com/securityalert/6601
http://www.acunetix.com/blog/websecuritynews/php-multipartform-data-denial-of-service/

или введите имя

CAPTCHA