Множественные уязвимости в Xoops

Дата публикации:
04.01.2010
Дата изменения:
04.01.2010
Всего просмотров:
1863
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Xoops 2.x
Уязвимые версии: Xoops 2.4.2, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1.Уязвимость существует из-за недостаточной обработки входных данных в параметре "op" в сценарии modules/pm/readpmsg.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости требуется, чтобы модуль Private Messaging был установлен на системе.

2. Уязвимость существует из-за недостаточной обработки входных данных, передаваемых через модули сторонних приозводителей, в параметре "not_list" в сценарии include/notification_update.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.xoops.org

Решение: Установите последнюю версию 2.4.3 с сайта производителя.

Ссылки: http://www.xoops.org/modules/news/article.php?storyid=5178

или введите имя

CAPTCHA