Переполнение буфера в qosmod и qoslist в IBM AIX

Дата публикации:
30.12.2009
Дата изменения:
30.12.2009
Всего просмотров:
1108
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-4361
CVE-2009-4362
Вектор эксплуатации:
Локальная
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
AIX 6.x
Уязвимые версии: IBM AIX 6.1

Описание:
Обнаруженные уязвимости позволяют локальному пользователю повысить свои привилегии на системе.

1. Уязвимость существует из-за ошибки в приложении qosmod. Локальный пользователь может передать слишком длинный аргумент qosmod, вызвать переполнение буфера и выполнить произвольный код на системе с повышенными привилегиями.

2. Уязвимость существует из-за ошибки в приложении qoslist. Локальный пользователь может передать слишком длинный аргумент qoslist, вызвать переполнение буфера и выполнить произвольный код на системе с повышенными привилегиями.

URL производителя: www-03.ibm.com/systems/p/os/aix/v61/index.html

Решение: Установите исправление IZ66917, IZ66918, IZ66966 и IZ66967 с сайта производителя.

Ссылки: http://www-01.ibm.com/support/docview.wss?uid=isg1IZ66917
http://www-01.ibm.com/support/docview.wss?uid=isg1IZ66918
http://www-01.ibm.com/support/docview.wss?uid=isg1IZ66966
http://www-01.ibm.com/support/docview.wss?uid=isg1IZ66967

или введите имя

CAPTCHA