Обход ограничений безопасности в KDE KHTML

Дата публикации:
15.12.2009
Дата изменения:
15.12.2009
Всего просмотров:
1363
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
KDE 4.x
Уязвимые версии: KDE KHTML версии до 4.3.3

Описание:
Уязвимость позволяет удаленному пользователю обойти некоторые ограничения безопасности и получить доступ к важным данным.

Уязвимость существует из-за ошибки в реализации XMLHttpRequest, которая позволяет отправку запросов KIO слейвам. В комбинации с другими ошибками это может привести к раскрытию произвольных локальных файлов.

URL производителя: www.kde.org

Решение: Установите последнюю версию 4.3.3 с сайта производителя.

Ссылки: http://www.kde.org/info/security/advisory-20091027-1.txt
http://www.portcullis-security.com/330.php
http://www.portcullis-security.com/331.php
http://www.portcullis-security.com/332.php
http://www.ocert.org/advisories/ocert-2009-015.html

или введите имя

CAPTCHA