Инклюдинг локальных файлов в SweetRice

Дата публикации:
03.12.2009
Дата изменения:
03.12.2009
Всего просмотров:
1412
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SweetRice 0.x
Уязвимые версии: SweetRice 0.5.4, возможно другие версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "root_dir" в сценариях _plugin/subscriber/inc/post.php и as/lib/news_modify.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости поддержка .htaccess файлов должна быть отключена.

URL производителя: http://www.basic-cms.org/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://packetstormsecurity.org/0911-exploits/sweetrice-rfilfi.txt