Ошибка завышения на единицу в Compress::Raw::Bzip2 модуле к Perl

Дата публикации:
19.08.2009
Дата изменения:
01.12.2009
Всего просмотров:
736
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Compress::Raw::Bzip2 2.x (модуль к Perl)
Уязвимые версии: Compress::Raw::Bzip2 (модуль к Perl) версии до 2.019

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки завышения на единицу в функции bzinflate() в Bzip2.xs. Удаленный пользователь может с помощью специально сформированных сжатых данных вызвать переполнение динамической памяти и скомпрометировать целевую систему. Уязвимость относится к:
www.securitylab.ru/vulnerability/381402.php

URL производителя: search.cpan.org/~pmqs/Compress-Raw-Bzip2/

Решение: Установите последнюю версию 2.019 с сайта производителя.

Ссылки: http://bugs.gentoo.org/show_bug.cgi?id=281955

или введите имя

CAPTCHA