Межсайтовый скриптинг и раскрытие данных в DotNetNuke

Дата публикации:
04.12.2009
Дата изменения:
04.12.2009
Всего просмотров:
982
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-4109
CVE-2009-4110
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
DotNetNuke 4.x
DotNetNuke 5.x
Уязвимые версии: DotNetNuke 4.0, 4.8, 5.1.4.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и получить доступ к важным данным.

1. Уязвимость существует из-за недостаточной обработки входных данных в поисковых параметрах перед возвращением пользователю. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за того, что мастер установки небезопасным образом отображает определенные страницы, содержащие информацию о версии продукта.

URL производителя: http://www.dotnetnuke.com/

Решение: Установите последнюю версию 5.2.0 с сайта производителя.

Ссылки: http://www.dotnetnuke.com/News/SecurityPolicy/securitybulletinno30/tabid/1449/Default.aspx
http://www.dotnetnuke.com/News/SecurityPolicy/securitybulletinno31/tabid/1450/Default.aspx

или введите имя

CAPTCHA