Переполнение буфера в Serenity

Дата публикации:
27.11.2009
Дата изменения:
27.11.2009
Всего просмотров:
1005
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Serenity 3.x
Уязвимые версии: Serenity 3.2.3, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции MplayInputFile() в файле src/plgui.c. Удаленный пользователь может с помощью специально сформированного M3U файла вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: malsmith.kyabram.biz/serenity/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Serenity Audio Player <= 3.2.3 Playlist .m3u Buffer Overflow PoC

или введите имя

CAPTCHA