Межконтекстный скриптинг в infoRSS расширении к Firefox

Дата публикации:
24.11.2009
Дата изменения:
24.11.2009
Всего просмотров:
2119
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
infoRSS 1.x (расширение к Firefox)
Уязвимые версии: infoRSS 1.1.4.2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за недостаточной обработки входных данных в RSS лентах перед воспроизведением данных в браузере. Удаленный пользователь может выполнить произвольный код сценария в контексте "chrome:" и выполнить произвольные команды на системе. Для успешной эксплуатации уязвимости пользователь должен подписаться на специально сформированную новостную ленту.

URL производителя: addons.mozilla.org/en-US/firefox/addon/361

Решение: Установите последнюю версию 1.2.0 или выше с сайта производителя.

Ссылки: https://addons.mozilla.org/en-US/firefox/addons/versions/361#version-1.2.0

или введите имя

CAPTCHA