Переполнение буфера в Deliantra Server

Дата публикации:
20.11.2009
Дата изменения:
20.11.2009
Всего просмотров:
912
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Deliantra Server 2.x
Уязвимые версии: Deliantra Server версии до 2.82

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки проверки границ данных в функции command_gsay() в файле server/c_party.c. Удаленный пользователь может вызвать переполнение стека и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за неизвестной ошибки в реализации "book". Удаленный пользователь может вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: www.deliantra.net/server_download.html

Решение: Установите последнюю версию 2.82 с сайта производителя.

Ссылки: http://cvs.schmorp.de/deliantra/server/Changes?pathrev=rel-2_82
http://cvs.schmorp.de/deliantra/server/server/c_party.C?r1=1.29&r2=1.30

или введите имя

CAPTCHA