Обход ограничений безопасности и межсайтовый скриптинг в Movable Type

Дата публикации:
22.07.2009
Дата изменения:
18.11.2009
Всего просмотров:
597
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-2480
CVE-2009-2481
CVE-2009-2492
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Movable Type 4.x
Уязвимые версии: Версии до Movable Type 4.26

Описание:
Уязвимость позволяет удаленному пользователю обойти ограничения безопасности и произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в сценарии mt-wizard.cgi перед возвращением пользователю. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный HTML код и код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за неизвестной ошибки в сценарии mt-wizard.cgi. Удаленный пользователь может обойти некоторые ограничения безопасности.

URL производителя: http://www.movabletype.org/

Решение: Установите последнюю версию 4.26 с сайта производителя.

Ссылки: http://www.movabletype.org/documentation/appendices/release-notes/426.html

или введите имя

CAPTCHA