Межсайтовый скриптинг и обход каталога в Php-I-Board

Дата публикации:
01.07.2009
Дата изменения:
18.11.2009
Всего просмотров:
696
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-2221
CVE-2009-2222
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Раскрытие системных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Php-I-Board 1.x
Уязвимые версии: Php-I-Board 1.2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и получить даступ к важным данным.

1. Уязвимость существует из-за недостаточной обработки входных данных перед возвращением пользователю. Удаленный пользователь может выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных перед прочтением файлов. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, прочитать произвольные файлы из локальных ресурсов.

URL производителя: http://php.s3.to/bbs/bbs8.php

Решение: Установите последнюю версию 1.2 с сайта производителя.

Ссылки: http://jvn.jp/jp/JVN20219071/index.html
http://jvn.jp/jp/JVN32788272/index.html

или введите имя

CAPTCHA