Переполнение буфера в HP Power Manager

Дата публикации:
10.11.2009
Дата изменения:
26.01.2010
Всего просмотров:
1832
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
HP Power Manager 4.x
Уязвимые версии: HP Power Manager 4.2.9, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке параметров URL, передаваемых форме авторизации в Web интерфейсе. Удаленный пользователь может с помощью специально сформированной переменной "Login" вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.hp.com

Решение: Установите последнюю версию 4.2.10 с сайта производителя.

Журнал изменений:

26.01.2010
Изменена секция «Решение».

Ссылки: HPSBMA02474 SSRT090107 rev.2 - HP Power Manager, Remote Execution of Arbitrary Code
ZDI-09-081: Hewlett-Packard Power Manager Administration Web Server Stack Overflow Vulnerability

или введите имя

CAPTCHA