Отказ в обслуживании в HTML-Parser

Дата публикации:
03.11.2009
Дата изменения:
03.11.2009
Всего просмотров:
1004
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
HTML-Parser 3.x
Уязвимые версии: HTML-Parser версии до 3.63

Описание:
Уязвимость позволяет удаленному пользователю произвести DoS атаку.

Уязвимость существует из-за ошибки в функции decode_entities() в файле utils.c. Удаленный пользователь может с помощью специально сформированной строки вызвать зацикливание приложения, использующего уязвимую библиотеку.

URL производителя: search.cpan.org/dist/HTML-Parser/

Решение: Установите последнюю версию 3.63 с сайта производителя.

Ссылки: http://github.com/gisle/html-parser/commit/b9aae1e43eb2c8e989510187cff0ba3e996f9a4c

или введите имя

CAPTCHA