Раскрытие важных данных в set_unix_mode() в GNOME GLib

Дата публикации:
26.10.2009
Дата изменения:
26.10.2009
Всего просмотров:
1128
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Раскрытие важных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GNOME GLib 2.x
Уязвимые версии: GNOME GLib версии до 2.22.1

Описание:
Уязвимость позволяет локальному пользователю получить доступ к важным данным.

Уязвимость существует из-за ошибки в функции set_unix_mode() при установке привилегий доступа к файлу. Локальный пользователь может получить доступ на чтение и запись к обычно запрещенным для доступа файлам. Для успешной эксплуатации уязвимости требуется, чтобы символические ссылки на защищенные файлы и каталоги были скопированы с помощью GLib, например Nautilus.

URL производителя: developer.gnome.org/arch/gtk/glib.html

Решение: Установите последнюю версию 2.22.1 с сайта производителя.

Ссылки: https://bugs.launchpad.net/ubuntu/+source/glib2.0/+bug/418135
https://bugzilla.gnome.org/show_bug.cgi?id=593406
http://www.openwall.com/lists/oss-security/2009/09/08/8

или введите имя

CAPTCHA