Множественные уязвимости в Poppler

Дата публикации:
16.10.2009
Дата изменения:
20.01.2010
Всего просмотров:
1198
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-3603
CVE-2009-3607
CVE-2009-3608
CVE-2009-3609
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
poppler 0.x
Уязвимые версии: Poppler 0.11.0, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Уязвимости существуют из-за использования уязвимого кода Xpdf. Подробное описание уязвимостей:
www.securitylab.ru/vulnerability/386613.php #1-2

2. Целочисленное переполнение обнаружено в функции create_surface_from_thumbnail_data() в файле glib/poppler-page.cc. Удаленный пользователь может с помощью специально сформированного PDF файла вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: poppler.freedesktop.org

Решение: Установите последнюю версию 0.12.2 с сайта производителя.

Журнал изменений:

20.11.2009
Изменена секция «Решение».
20.01.2010
Незначительные изменения.

Ссылки: https://bugzilla.redhat.com/show_bug.cgi?id=526915
https://bugzilla.redhat.com/show_bug.cgi?id=526637
https://bugzilla.redhat.com/show_bug.cgi?id=526893
https://bugzilla.redhat.com/show_bug.cgi?id=526924

или введите имя

CAPTCHA