Переполнение буфера в httpdx

Дата публикации:
09.10.2009
Дата изменения:
09.10.2009
Всего просмотров:
1752
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
httpdx 1.x
Уязвимые версии: httpdx 1.4.3, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции h_handlepeer() в файле http.cpp. Удаленный пользователь может с помощью специально сформированного HTTP запроса вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: httpdx.sourceforge.net

Решение: Установите последнюю 1.4.4 версию с сайта производителя.

или введите имя

CAPTCHA