Переполнение буфера в rpc.cmsd в IBM AIX

Дата публикации:
08.10.2009
Дата изменения:
08.10.2009
Всего просмотров:
1266
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
AIX 5.x
AIX 6.x
IBM Virtual I/O Server (VIOS) 1.x
IBM Virtual I/O Server (VIOS) 2.x
Уязвимые версии:
IBM AIX 5.3 и 6.1
IBM Virtual I/O Server (VIOS) версии 1.4, 1.5 и 2.1, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в библиотеке libcsa.a. Удаленный пользователь может с помощью специально сформированного RPC запроса к Calendar Manager Service Daemon (rpc.cmsd), содержащего слишком длинный аргумент для удаленной процедуры 21, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.ibm.com

Решение: Установите исправление с сайта производителя.

Ссылки: iDefense Security Advisory 10.07.09: IBM AIX rpc.cmsd Stack Buffer Overflow Vulnerability
http://aix.software.ibm.com/aix/efixes/security/cmsd_advisory.asc

или введите имя

CAPTCHA