Межсайтовый скриптинг в Drupal Browscap Module

Дата публикации:
07.10.2009
Дата изменения:
07.10.2009
Всего просмотров:
1165
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal Browscap Module 5.x
Drupal Browscap Module 6.x
Уязвимые версии: Drupal Browscap Module версии до 5.x-1.1 и 6.x-1.1

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в HTTP заголовке "User-Agent". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: drupal.org/project/browscap

Решение: Установите последнюю версию 5.x-1.1 или 6.x-1.1 с сайта производителя.

Ссылки: http://drupal.org/node/592272

или введите имя

CAPTCHA