Множественные уязвимости в Samba

Дата публикации:
02.10.2009
Дата изменения:
02.10.2009
Всего просмотров:
2015
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Samba 3.x
Уязвимые версии: Samba версии до 3.0.37, 3.2.15, 3.3.8 и 3.4.2

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к важным данным и вызвать отказ в обслуживании.

1. Уязвимость существует из-за того, что приложение mount.cifs недостаточно проверяет права пользователя на открытие файла привилегий. Злоумышленник может передать файлу mount.cifs с опцией "--verbose" или "-v" и файл привилегий и просмотреть часть содержимого файла. Для успешной эксплуатации уязвимости для mount.cifs дожжен быть установлен setiud бит.

2. Уязвимость существует из-за ошибки при обработке определенных SMB пакетов. Удаленный аутентифицированный пользователь может с помощью специально сформированного запроса вызвать зацикливание приложения.

3. Уязвимость существует из-за ошибки при обработке строк в файле /etc/passwd с пустой домашней директорией. Злоумышленник может получить доступ к директории root и ее подкаталогам. Для успешной эксплуатации уязвимости в файле /etc/passwd должна быть запись с пустой домашней директорией и должен использоваться автоматический общий доступ к домашним директориям или должен быть открыт сетевой доступ папке с именем пользователя уязвимой записи.

URL производителя: www.samba.org

Решение: Установите последнюю версию 3.0.37, 3.2.15, 3.3.8 или 3.4.2 с сайта производителя.

Ссылки: http://www.samba.org/samba/security/CVE-2009-2948.html
http://www.samba.org/samba/security/CVE-2009-2906.html
http://www.samba.org/samba/security/CVE-2009-2813.html

или введите имя

CAPTCHA