Множественные уязвимости в IBM DB2

Дата публикации:
01.10.2009
Дата изменения:
26.11.2009
Всего просмотров:
1527
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
IBM DB2 9.x
Уязвимые версии: IBM DB2 9.x

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности.

1. Уязвимость существует из-за неизвестной ошибки, которая позволяет вставить, изменить и удалить строки не имея необходимых привилегий. Уязвимость распространяется на версии DB2 9.1 до FP8 и DB2 9.5 до FP4.

2. Уязвимость существует из-за неизвестной ошибки, относящейся к таблице функций. Уязвимость распространяется на версии DB2 9.1 до FP8 и DB2 9.5 до FP4.

3. Уязвимость существует из-за ошибки при обработке команды "SET SESSION AUTHORIZATION". Злоумышленник может выполнить запрос не имея необходимых привилегий. Уязвимость существует в версии DB2 9.1 до FP8.

4. Уязвимость существует из-за того, что команда "DASAUTO" может быть запущена непривилегированным пользователем. Уязвимость существует в версиях DB2 9.1 до FP8 и DB2 9.5 до FP4.

URL производителя: www-306.ibm.com/software/data/db2/9/

Решение: Установите последнюю версию DB2 9.1 FP8 или DB2 9.5 FP4 с сайта производителя.

Журнал изменений:

26.11.2009
Добавлено уязвимость #4.

Ссылки: http://www-01.ibm.com/support/docview.wss?uid=swg21403619
http://www-01.ibm.com/support/docview.wss?uid=swg21386689

или введите имя

CAPTCHA