SQL-инъекция в SaphpLesson

Дата публикации:
23.09.2009
Дата изменения:
23.09.2009
Всего просмотров:
1981
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SaphpLesson 4.x
Уязвимые версии: SaphpLesson 4.3, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в HTTP заголовке "CLIENT_IP". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

URL производителя: www.saphplesson.org

Решение: Установите последнюю версию с сайта производителя.

Ссылки: Saphplesson 4.3 Remote Blind SQL Injection Exploit

или введите имя

CAPTCHA