Множественные уязвимости в PaoBacheca

Дата публикации:
22.09.2009
Дата изменения:
22.09.2009
Всего просмотров:
2280
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PaoBacheca 2.x
Уязвимые версии: PaoBacheca 2.1, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и обойти некоторые ограничения безопасности..

1. Уязвимость существует из-за недостаточной обработки входных данных в URL в сценарии scrivi.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за использования неинициализированной переменной в сценарии login.php. Удаленный пользователь может установить параметр "login_ok" в произвольное значение, отличное от 0, и получить доступ к административной секции приложения. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: zenas.org/paobacheca/

Решение: Способов устранения уязвимости не существует в настоящее время.

Журнал изменений:

22.09.2009
Изменено описание уязвимости.

Ссылки: http://packetstormsecurity.org/0909-exploits/paobacheca-xss.txt
http://milw0rm.com/exploits/9293

или введите имя

CAPTCHA