Множественные уязвимости в Drupal OpenID Module

Дата публикации:
21.09.2009
Дата изменения:
21.09.2009
Всего просмотров:
2669
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Внедрение в сессию пользователя
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal OpenID Module 5.x
Уязвимые версии: Drupal OpenID Module версии до 5.x-1.3

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю внедриться в сессию пользователя и произвести XSS нападение.

1. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов при выполнении некоторых действий. Удаленный пользователь может произвести CSRF нападение и добавить OpenID идентификаторы к существующим учетным записям. Подробное описание уязвимости:
www.securitylab.ru/vulnerability/385676.php #1

2. Уязвимость существует из-за ошибки в реализации OpenID Authentication 2.0. Удаленный пользователь может внедриться в сессию пользователя, если используется тот же OpenID 2.0 провайдер. Подробное описание уязвимости:
www.securitylab.ru/vulnerability/385676.php #2

URL производителя: drupal.org/project/openid

Решение: Установите последнюю версию 5.x-1.3 с сайта производителя.

Ссылки: http://drupal.org/node/579478

или введите имя

CAPTCHA