Множественные уязвимости в Drupal

Дата публикации:
21.09.2009
Дата изменения:
21.09.2009
Всего просмотров:
4440
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Внедрение в сессию пользователя
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal 6.x
Уязвимые версии: Drupal версии до 6.14

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю внедриться в сессию пользователя, произвести XSS нападение и скомпрометировать целевую систему.

1. Уязвимость существует из-за того, что OpenID модуль недостаточно проверяет подлинность HTTP запросов при выполнении некоторых действий. Удаленный пользователь может произвести CSRF нападение и добавить OpenID идентификаторы к существующим учетным записям.

2. Уязвимость существует из-за ошибки в реализации OpenID Authentication 2.0. Удаленный пользователь может внедриться в сессию пользователя, если используется тот же OpenID 2.0 провайдер.

3. Уязвимость существует из-за ошибки в File API при обработке определенных расширений файлов. Удаленный пользователь может загрузить произвольные файлы и выполнить их на системе с привилегиями Web сервера. Для успешной эксплуатации уязвимости Web сервер должен игнорировать ".htaccess" файл приложения.

URL производителя: drupal.org

Решение: Установите последнюю версию 6.14 с сайта производителя.

Ссылки: http://drupal.org/node/579482

или введите имя

CAPTCHA