Уязвимость при обработке X.509 сертификатов в GnuTLS

Дата публикации:
14.08.2009
Дата изменения:
21.09.2009
Всего просмотров:
930
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Спуфинг атака
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GnuTLS 2.x
Уязвимые версии: GnuTLS версии до 2.8.2

Описание:
Уязвимость позволяет удаленному пользователю произвести спуфинг атаку.

Уязвимость существует из-за ошибки при обработке CN и SAN полей, содержащих символ '\0' в X.509 сертификатах. Удаленный пользователь может с помощью специально сформированного X.509 сертификата не позволит приложению отобразить полное содержимое CN и SAN полей и произвести атаку «человек посередине» против аутентифицированной TLS сессии.

URL производителя: www.gnu.org/software/gnutls/

Решение: Установите последнюю версию 2.8.3 с сайта производителя.

Журнал изменений:

21.09.2009
Незначительные изменения.

Ссылки: http://article.gmane.org/gmane.network.gnutls.general/1733

или введите имя

CAPTCHA