Переполнение буфера в irssi

Дата публикации:
15.09.2009
Дата изменения:
15.09.2009
Всего просмотров:
1120
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
irssi 0.x
Уязвимые версии: irssi 0.8.13, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести DoS атаку.

Уязвимость существует из-за ошибки завышения на единицу в функции event_wallops() в файле fe-common/irc/fe-events.c. Удаленный пользователь может с помощью специально сформированного WALLOPS сообщения вызвать однобайтное переполнение буфера и аварийно завершить работу приложения.

URL производителя: www.irssi.org

Решение: Установите последнюю версию 0.8.14 с сайта производителя.

Ссылки: [ GLSA 200909-13 ] irssi: Execution of arbitrary code
http://www.irssi.org/news/ChangeLog
http://xorl.wordpress.com/2009/05/28/irssi-event_wallops-off-by-one-readwrite/
http://bugs.irssi.org/index.php?do=details&task_id=662

или введите имя

CAPTCHA