Множественные уязвимости в Horde Application Framework

Дата публикации:
15.09.2009
Дата изменения:
15.09.2009
Всего просмотров:
1236
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Horde Application Framework 3.x
Уязвимые версии: Horde Application Framework версии до 3.2.5 и 3.3.5

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки в библиотеке форм при обработке полей изображений. Удаленный пользователь может перезаписать произвольные файлы на системе. Для успешной эксплуатации уязвимости приложение должно использовать уязвимые поля (например, Ansel или Turba) и удаленный пользователь должен иметь привилегии на запись.

2. Уязвимость существует из-за ошибки в библиотеке MIME Viewer во время воспроизведения неизвестных частей текста. Удаленный пользователь может выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта при просмотре специально сформированных данных.

3. Уязвимость существует из-за недостаточной numeric preference типов. Удаленный пользователь может выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.horde.org/horde/

Решение: Установите последнюю версию 3.2.5 или 3.3.5 с сайта производителя.

Ссылки: http://marc.info/?l=horde-announce&m=125292339907481&w=2
http://marc.info/?l=horde-announce&m=125291625030436&w=2
http://bugs.horde.org/ticket/?id=8311
http://bugs.horde.org/ticket/?id=8399

или введите имя

CAPTCHA