Множественные уязвимости в Nullam Blog

Дата публикации:
14.09.2009
Дата изменения:
14.09.2009
Всего просмотров:
851
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Nullam Blog 0.x
Уязвимые версии: Nullam Blog версии до 0.1.3

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, выполнить произвольные SQL команды в базе данных приложения и получить доступ к важным данным.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "e" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "i" и "v" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "p" и "s" в сценарии "index.php". Удаленный пользователь может с помощью специально сформированного запроса просмотреть содержимое произвольных файлов на системе.

URL производителя: sourceforge.net/projects/nullam/

Решение: Установите последнюю версию 0.1.3 с сайта производителя.

Ссылки: http://milw0rm.com/exploits/9625

или введите имя

CAPTCHA