Переполнение буфера в FTPShell Client

Дата публикации:
10.09.2009
Дата изменения:
10.09.2009
Всего просмотров:
1057
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FTPShell Client 4.x
Уязвимые версии: FTPShell Client 4.1 RC2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке FTP ответов. Удаленный пользователь, контролирующий FTP сервер, может с помощью слишком длинного PASV ответа вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.ftpshell.com/client/index.htm

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: FTPShell Client 4.1 RC2 Remote Buffer Overflow Exploit (univ)

или введите имя

CAPTCHA