Множественные уязвимости в Apple QuickTime

Дата публикации:
10.09.2009
Дата изменения:
11.09.2009
Всего просмотров:
1296
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apple QuickTime 7.x
Уязвимые версии: Apple QuickTime версии до 7.6.4.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки при обработке H.264 видео файлов. Удаленный пользователь может вызвать повреждение памяти и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки при обработке MPEG-4 видео файлов. Удаленный пользователь может вызвать переполнение буфера и выполнить произвольный код на целевой системе.

3. Целочисленное переполнение обнаружено при обработке "SectorShift" и "cSectFat" полей в заголовках FlashPix файла. Удаленный пользователь может с помощью специально сформированного .fpx файла вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

4. Уязвимость существует из-за ошибки при обработке примеров из H.264 кодированных MOV файлов. Удаленный пользователь может с помощью специально сформированного MOV файла вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.apple.com

Решение: Установите последнюю версию 7.6.4 с сайта производителя.

Журнал изменений:

11.09.2009
Изменено описание уязвимостей согласно данным от ZDI.

Ссылки: About the security content of QuickTime 7.6.4
ZDI-09-063: Apple QuickTime H.264 Nal Unit Length Heap Overflow Vulnerability
ZDI-09-064: Apple QuickTime FlashPix Sector Size Overflow Vulnerability

или введите имя

CAPTCHA